View Data Basics - Selecting, Deleting, Menus

Follow

Selecting Projects and Forms

Your doForms database is organized by “Projects” which in turn contain the “Forms”. Note that the forms contain and organize the data and any form may be listed under multiple projects (See Understanding Forms, Projects and Mobile Units). 

To view data first Select a Project from the drop-down list. Next Select a Form.  Next enter a Date Range. These will narrow down the volume of data that will be displayed. Finally, click the View button.

The data corresponding to the selection will be displayed. You can control how many data rows are displayed on a page using the controls at the top and bottom right side of the page.

Deleting Projects and Forms

In order to delete all the data corresponding to a form from your account, you must (1) delete the form in the Build Forms tab, and (2) remove the form from any projects in your account.

See the Build Forms section for information on deleting forms from your account.

See the Manage > Projects section for information on removing forms from projects in your account.

Deleting Data Records

In order to delete any or all records from your doForms website:

  • Select a project/form in the View Data tab.
  • Select the record that you wish to delete using the check boxes on the left side of each record (or check the box above all the records to “select all”).
  • Click the “Delete all selected” button.

File Menu

The File menu provides the following functions:

Save Data As – Allows the currently displayed data to be exported onto your local hard drive in Excel, CSV, HTML, Text, KML, OpenOffice or PDF formats. You can also export the data into your online Google Docs account. Once it is exported into your Google Docs account, you can perform a variety of spreadsheet, analysis and reporting functions on the data, as well as share it with other Google Docs users.  When selecting the Google Docs option, you will be prompted for your Google Docs username and password, and you will also be asked to grant permission for doForms to connect with your Google Docs account. 

Print – Prints the currently displayed data. Be sure to select “Landscape” layout in your browser print preferences. If you need additional formatting for your printouts, try one of the “Save as” options to get the data into another program, like Google Docs or Excel, then do the additional formatting in that program.

Import Data – The Import Data function allows you to import data from an external table into the Dispatch tab. External files can be CSV or Excel 97-2003 format only and first row of the file must contain field names for each column (no spaces or special characters). The corresponding data types (number, text, date etc.) must match the data types in the View Data tab exactly. The Import Data function will allow you the option of “mapping fields” in the event that the column names in the file and the data_names in the View Data tab do not match. Note that the maximum file size that can be imported is 5 MB. If your file is larger, please break it up into smaller files and import them one at a time.

IMPORTANT: Note that it is the currently displayed data (i.e., the Current Query) that is processed by the options above (see “Sorting and Filtering Data” below).

Options Menu

The Options menu provides the following functions to display how data is presented in the View Data tab:

Display Settings – Use to specify which questions will be displayed as answer columns in the List View. Use these setting to declutter the List View. You may also specify if the “caption” or “data_name” property of the question widget will be displayed as the heading for the corresponding column. These settings are “per user”. This means that each web user can change the setting for a specific project/form without affecting other users.

Export Settings  Use to control how data will be exported with File > Save as options.  “Column Headings” specifies if the “caption” or “data_name” property of the question widget will be displayed as the heading for the corresponding export column.  “Choose-one questions” specifies how the answers to these questions will be exported.  “Select-multiple questions” specifies how the answers to select-multiple questions will be exported.  Options for choose-one and select-multiple include reporting “underlying values” in one column, or as “0/1” values in multiple columns.  These settings are “per account”.  This means that any changes to these settings for a particular project/form affect all website users.

Report Settings – Use to control the format of PDF and Excel reports that are created from the Row Menu > PDF Report and Excel Report functions. These settings are “per account”. This means that any changes to these settings for a particular project/form affect all website users.

Map Callout Settings – Use to specify which questions/answer fields will be included in the map callouts in the Map View. The “callouts” are small data summaries which are displayed when a map icon is clicked. See the illustration below. These setting are “per user”. This means that each web user can change the settings for a specific project/form without affecting other users.

Data Menu

The Data menu provides the following functions for managing data in the View Data tab:

Add Record – Adds a new blank record into the data table in Edit mode.

Show Data Filter – Displays the data filter options. See “Sorting and Filtering Data” below.

Delete All Selected – Deletes all selected (checked) records.

Unlock All Selected – Unlocks all selected (checked) records.

PDF Report All Selected – Creates PDF Reports for all selected (checked) records.  For more information, see the “Reports” chapter.

Excel Report All Selected – Creates Excel Reports for all selected (checked) records. For more information, see the “Reports” chapter.

View Menu

The View menu provides the following functions:

View Map – Toggles from List View to Map View (See Map View section below.)

List View – Toggles from Map View to List View.

 

Row Menu

 

Each data row in the View Data tab contains a “Row Menu” (little boxes with down-arrow). The Row Menus in the View Data tab provide the following functionality:

Map – Displays the data for this row on a map (will only be displayed if data row contains GPS map coordinates). To display data in a row on a map, select Map from the Row Menu. A new browser window will open with the selected data record icon displayed on the map (see below). Click on icon to display the data values for the record being mapped.

Edit – Allows you to edit the data. To make changes to data in a row, select Edit from the Row Menu; the selected row will expand. Make the desired edits and press the Submit when done. The changes will be saved to your doForms website.  Otherwise, press Cancel.

Add – Allows you to add a new data row below. To add a new row of data, select Add from the Row Menu. The new empty data row will be added below. Fill in the data fields and press the Submit button when done. The new row will be saved to your doForms website. Otherwise, press Cancel. Note that if the form has a media question, you will be able to upload the corresponding media files from your local hard drive if desired.

PDF Report – Produces a PDF report of the selected record. For more information, see the “Reports” chapter. PDF reports can be downloaded, emailed or printed.

Excel Report – Produces an Excel report of the selected record. For more information, see the “Reports” chapter. Excel reports can be downloaded, emailed or printed.

Delete – Deletes the data row. To delete a row of data, select Delete from the Row Action Menu. A message will be displayed asking you to confirm the delete. Click the Ok button to permanently delete the row of data from your doForms website.  Otherwise, press Cancel.

Task – Use to send an email to one or more doForms website users instructing them to complete a task(s) pertaining to the data row. The email will contain a direct link back to the data record.

IMPORTANT: Edit, Add and Delete functions are only available to users with Edit, Manage or Admin privileges.  Also, please make sure that your web browser is set to “Allow Pop-ups” from your doForms website in order to use the Print, Email PDF and Task functions above.

 

Have more questions? Submit a request

Comments

Powered by Zendesk